Get in touch
Back
Resolved

Cloud services provider outage [DNS]

Started 24 Aug at 07:27am EDT.

BTM Kiosk Services Customer Portal Transaction Processor BTM Data services Partner API Cash API Bitcoin Wallet Service BTM Operator Panel
Created

At approximately 11:17pm GMT on August 23th, 2022 Bitaccess's monitoring services detected DNS lookup errors reaching our production services.

After investigation, this was caused by a failure in the systems of a core upstream cloud service provider. The root cause of this issue is an incident at NS1, a very large name service provider (https://ns1status.com/#!/incident/365716). This incident had the downstream effect of impacting Heroku (https://status.heroku.com/incidents/2453), which is a critical service provider to Bitaccess.

While Bitaccess has the ability to route traffic across regions at times of service instability, this issue impacted all traffic being routed into an out of the cloud service provider. Both NA and EU regions were impacted.

The incident was resolved through no intervention by Bitaccess at approximately 01:08am GMT on August 24, 2022.

Posted 24 Aug at 07:27am EDT.